zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andor Molnar <an...@apache.org>
Subject Re: Migrate from 3.4.x to 3.5.5
Date Mon, 26 Aug 2019 12:41:35 GMT
Hi Zili,

There’s no migration guide available for 3.5, because it shouldn’t break any existing
functionality and no need to upgrade the database either.

I’ve created a wiki page to collect upgrade experiences from users which could give you
some hint if you’re facing problems: https://cwiki.apache.org/confluence/display/ZOOKEEPER/Upgrade+FAQ

You can always drop an email here too to get help.

Andor



> On 2019. Aug 26., at 14:12, Zili Chen <wander4096@gmail.com> wrote:
> 
> Detailedly, in Flink community we try to bump ZooKeeper version from 3.4.10
> to 3.5.5 but without accurate idea about how it would break existing
> systems.
> Mainly we make use of the "client" of ZooKeeper.
> 
> 
> Zili Chen <wander4096@gmail.com> 于2019年8月26日周一 下午8:02写道:
> 
>> Hi,
>> 
>> Is there any migration guide for potentially breaking changes and how to
>> deal with them?
>> 
>> Best,
>> tison.
>> 


Mime
View raw message