zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Heisey <apa...@elyograg.org>
Subject Re: Issues with using ZooKeeper 3.5.5 together with Solr 8.2.0
Date Tue, 30 Jul 2019 16:12:43 GMT
On 7/29/2019 11:45 PM, Enrico Olivelli wrote:
> Due to potential security risks since ZK 3.5 you have to explicitly
> whitelist some commands.

The 3.5.5 documentation says that "*" can be used to whitelist all commands.

But what you just said seems to contradict that.  If your statement is 
more accurate, then the documentation should be updated to list the 
commands that are NOT enabled when using a wildcard.

There is a SOLR issue to upgrade the client in Solr to 3.5.5:

https://issues.apache.org/jira/browse/SOLR-8346

A comment was made on this issue saying that the following config is 
needed when the server is running 3.5.x:

4lw.commands.whitelist=mntr,conf,ruok

Thanks,
Shawn

Mime
View raw message