zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From João Medeiros <j...@simbioseventures.com.INVALID>
Subject Zookeeper Backup & Restore problem
Date Wed, 14 Nov 2018 11:52:30 GMT
Hello all,

Please, I kindly ask for some help regarding ZooKeeper backup and restore
of data files.

We were running a 5 node ZooKeeper cluster on version 3.4.11.

We had to migrate to a new (more powerful) 3 node cluster running version
3.4.13, a newest version.

In order to backup and restore the existing data to the new cluster, as
indicated on Stackoverflow and on the ZooKeeper book itself, we simply
copied these files below from the master node of the existing 5 node
cluster, to the data dir of the master node of the new 3 node cluster:
- log.6400064f0d
- snapshot.6400064f0b
- acceptedEpoch
- currentEpoch

When we start the master node of the new 3 node cluster, CPU consumption
increases a lot for a very long time (dozens of minutes) but the node never
starts, the log just shows this message:

---
INFO Reading snapshot /mnt/zookeeper/data/version-2/snapshot.6400064f0b
(org.apache.zookeeper.server.persistence.FileSnap)
---

We tried copying all the files to just the master node of the new cluster
and also to all nodes of the new cluster, but none of the options worked.

An important detail is that our snapshot is almost 1 GB, but this shouldn't
affect restore, right?

Please, is there any problem when restoring data from a past version
(3.4.11) to a newest version (3.4.11)? Or, am I doing something wrong?

Thanks in advance.

Regards,
João

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message