zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tu...@viettel.com.vn
Subject Issue about zookeeper in Hbase
Date Tue, 05 Jun 2018 08:33:22 GMT
Dear Mr/Mrs, 

I am an Hbase user who is trying to install Hbase on 4 node cluster. But I encountered an
error that took me one week to fix but I still can not work it around. 

I used Zookeeper emsemble in Hbase, and I setup Zookeeper Quorum on 3 out of 4 nodes. When
I started hbase, I did jps on all nodes and see that HQuorumPeers started on all assigned
nodes. 
But when I did a quick check on status of these Zookeeper instances using command:"echo stat
| nc localhost 2181 ", the 3rd node throws a message as: "This zookeeper instance is not currently
serving requests" 
while the 2 remaining nodes is started ok, and did vote their leader/follower for quorum.

Inside the zookeeper's logs of these nodes, nothing abnomal shows up. There're only logs about
FastLeaderElection. 

Then, I did try to telnet from a client to all of these nodes in Quorum and the messages indicate
that I can connect to these nodes via port 2181. 
But when I try to run a Java program in this client machine to connect to the Hbase cluster,
it shows an error that: "Can't connect to Zookeeper" 
I tried to investigate deeper but to this point, I can not provide more information of the
error. But if you want to know more about my configs or logs, please let me know. 

Please help me out with this problem. 
Hope to hearing from you soon. 
Thanks and Best Regards, 
Tu 



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message