zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Norbert Kalmar <nkal...@cloudera.com>
Subject Re: Error starting zookeeper using bash on Windows 10
Date Mon, 30 Apr 2018 22:45:44 GMT
Hi,

The zkServer.sh sets the classpath itself (with -cp, but including
CLASSPATH variable). You don't need to set it manually.
But if that doesn't work, for jar file, you have to include the .jar file.
So it is not enough to set the directory where the .jar file is, you have
to specify the .jar file. i.e.:
C:\DevelopmentTools\zookeeper\zookeeper-3.4.10\zookeeper.jar

Let me know if it is still not working. You can try to print the classpath
with echo to see if the .jar file is included (or the root package).

By the way, if you are using linux bash, I would also try to use forward
slash, as backslash tend to be problematic sometimes.

Hope this helps.

Regards,
Norbert





On Sun, Apr 29, 2018 at 7:41 PM, THADC <timothy.hadley.clotworthy@gmail.com>
wrote:

> Hello,
>
> I am not sure whether my problem has anything to do with bash exactly, but
> I
> am trying to run zookeeper server (3.4.10) for the first time. By the way,
> I
> did search for this in archive but could not find a match that worked for
> me.
>
> When I started it in foreground mode, I get the following:
>
> *$ ./bin/zkServer.sh start-foreground
> ZooKeeper JMX enabled by default
> Using config:
> /c/DevelopmentTools/zookeeper/zookeeper-3.4.10/bin/../conf/zoo.cfg
> Error: Could not find or load main class
> org.apache.zookeeper.server.quorum.QuorumPeerMain*
>
> , that class is in the zookeeper-3.4.10.jar, which is directly in the
> zookeeper-3.4.10 root directory. I added that directory to my classpath:
>
> *$ echo $CLASSPATH
> C:\Program Files\Java\jdk1.8.0_112\bin;C:\Program
> Files\Java\jre1.8.0_112\bin;C:\DevelopmentTools\zookeeper\
> zookeeper-3.4.10*
>
> , so as you can see above, the directory is in the classpath, but I am
> still
> getting the error. Any ideas what my problem is?
>
> Thank you!
>
>
>
>
> --
> Sent from: http://zookeeper-user.578899.n2.nabble.com/
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message