zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andor Molnar <an...@cloudera.com>
Subject Re: Upgrade required Java version to 1.8 on 3.5+
Date Tue, 17 Apr 2018 12:43:13 GMT
Hi Zk users,

Please be aware that ZooKeeper master and 3.5 branches have been upgraded
to Java 8.
Prior Java versions are no longer supported on these branches.

(Thanks to Norbert Kalmar and Michael Han for the work and everybody for
the participation.)

Regards,
Andor




On Fri, Mar 9, 2018 at 8:49 AM, Andor Molnar <andor@cloudera.com> wrote:

> Hi Shawn,
>
> Thanks for the feedback and thanks for everybody else too.
>
> The short term plan is to introduce Java 8 in next upcoming stable
> release, 3.5.
> Jumping 2 Java versions seems to be too much for me too.
>
> ZK master branch is going to be 3.6 release in which we can talk about
> upgrading to Java 9.
> What becomes later - I don't know - currently there's no plan for a 4.0
> release as far as I'm concerned.
>
> Regards,
> Andor
>
>
>
> On Fri, Mar 9, 2018 at 12:55 AM, Shawn Heisey <apache@elyograg.org> wrote:
>
>> On 3/7/2018 1:21 PM, Jeff Widman wrote:
>> > +1 from me to using Java 8 or even going all the way to 9 for the 3.5
>> > release branch.
>>
>> I don't think it would be a good idea to require Java 9 at this time.
>> It's probably already an uphill battle for sysadmins to get approval to
>> jump ONE major version.  Getting approval to upgrade through TWO major
>> versions might prove to be very difficult for some.
>>
>> A year from now, after Java 8 goes end of support, might be the time to
>> have that discussion.
>>
>> I have no idea what kind of overall roadmap there is for ZK major
>> versions.  Maybe nobody has planned that far ahead.
>>
>> Ordinarily I would say that requiring a new major Java version should
>> happen in a major release, which would mean requiring Java 8 with the
>> 4.0 release and Java 9 with the 5.0 release.  But I know that ZK has a
>> very slow release cycle -- multiple months between *point* releases, and
>> far longer between minor releases.  I don't even know what kind of cycle
>> there is for major releases.  Maybe because of the slow release cycle,
>> waiting for 4.0 would just take too long.  So here's an alternate idea:
>> require Java 8 in 3.6.x and Java 9 in whatever minor or major release
>> comes after 3.6.
>>
>> For comparison purposes -- Lucene/Solr usually puts out a new minor
>> release every few weeks.  Point releases usually are VERY quick after a
>> minor release, and typically are only created for really massive bugs.
>>
>> Thanks,
>> Shawn
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message