zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Enrico Olivelli <eolive...@gmail.com>
Subject Re: Upgrade required Java version to 1.8 on 3.5+
Date Wed, 07 Mar 2018 16:09:08 GMT
Hi,
At BookKeeper we are supporting java 8 onwards and we are using 3.5
branch. (Speaking as BookKeeper PMC)

In my company we running all on java8 and we switching to java9, both
clients and servers

So good to see Zookeeper moving to java8

Enrico


Il mer 7 mar 2018, 12:04 Andor Molnar <andor@cloudera.com> ha scritto:

> Hi ZooKeeper users,
>
> There's an ongoing discussion on the dev list about upgrading the required
> Java version to 1.8 on trunk and 3.5 branches.
>
> We'd like to get some feedback from a bigger audience if anybody or any
> other component that is dependent on ZooKeeper has any concerns or
> objections against the change?
>
> I've quickly checked some of the major components that are heavy Zk
> clients:
>
> Hadoop/HDFS = 1.8 required
> HBase = 1.8 required
> Kafka = 1.7 required (has some 1.8 and 1.9 bindings)
> Hive = 1.8 required
> Curator = 1.7 required (has 1.8-only async module to take advantage of Java
> lambdas)
> Solr  = 1.8
>
> As always, your feedback is much appreciated.
>
> Thanks,
> Andor
>
-- 


-- Enrico Olivelli

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message