zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Abraham Fine <af...@apache.org>
Subject Re: local call latency
Date Thu, 26 Oct 2017 15:58:04 GMT
Hi Ram-

I don't see any jstack output attached to the email.

Thanks,
Abe


On Wed, Oct 25, 2017, at 18:17, rammohan ganapavarapu wrote:
> Abe,
> 
> Under /node1 i have 30 child nodes but each child node doesn't have
> any more nodes. I did took jstack at the time of latency, please find
> the attached. It is happening with most of the servers i didn't check
> all of them.> 
> Thanks,
> Ram
> 
> On Wed, Oct 25, 2017 at 4:06 PM, Abraham Fine
> <afine@apache.org> wrote:>> That's strange. ZooKeeper's reads happen locally
usually quickly.
>> 
>>  Can you tell us anything else about the issue? Could you possibly
>>  provide a jstack output from a server that is slow to respond?  Does>>  this
happen with all of the servers? Does it matter if the node
>>  you are>>  reading from has many children?
>> 
>>  Thanks,
>>  Abe
>> 
>> 
>> On Wed, Oct 25, 2017, at 09:18, rammohan ganapavarapu wrote:
>>  > Hi,
>>  >
>>  > We have a multi region zk cluster, we are observing latency for
>>  > just>>  > local
>>  > zk 'ls' command intermittently nothing in logs dont know how to
>>  > find>>  >  reason for latency, any one have any thoughts?
>>  >
>>  > zkCli.sh ls /node1
>>  >
>>  > real 0m13.089s --When latency
>>  > real 0m0.689s -- No latency
>>  >
>>  > Thanks,
>>  > Ram


Mime
  • Unnamed multipart/alternative (inline, 7-Bit, 0 bytes)
View raw message