zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raghav <raghavas...@gmail.com>
Subject Re: ZooKeeper issues with 3.4.9 - Please help
Date Mon, 21 Aug 2017 21:09:35 GMT
On a fresh install, it worked fine.

By the way, is it alright to run zookeeper in multi server mode even if I
have only one zookeeper server ?

Thanks.

On Mon, Aug 21, 2017 at 1:42 PM, Abraham Fine <afine@apache.org> wrote:

> Very strange.
>
> How long after you launch the zookeeper process is it killed?
>
> I would guess that there is an issue binding to the selected port, but
> normally there is an exception when that occurs.
>
> Abe
>
> On Sun, Aug 20, 2017, at 10:17, Raghav wrote:
> > Hi
> >
> > I am trying to use the zookeeper 3.4.9 build (and jars) from apache
> > zookeeper's site with Kafka 10.2.1. I want to run a 3 node zk cluster
> > eventually, but to begin with I have only one node. I created my zoo.cfg
> > as
> > follows:
> >
> > tickTime=2000
> > dataDir=/var/lib/zookeeper/
> > clientPort=2181
> > initLimit=5
> > syncLimit=2
> > server.1=zoo1:2888:3888
> >
> >
> > The following are the logs once I start the zookeeper from command line.
> > You can see that towards the end it is killed. Any help is greatly
> > appreciated.
> >
> > $ *java -cp
> > zookeeper-3.4.9.jar:lib/log4j-1.2.16.jar:lib/slf4j-log4j12-
> 1.6.1.jar:lib/slf4j-api-1.6.1.jar:conf
> > org.apache.zookeeper.server.quorum.QuorumPeerMain conf/zoo.cfg*
> >
> > 2017-08-20 07:16:22,812 [myid:] - INFO  [main:QuorumPeerConfig@124] -
> > Reading configuration from: conf/zoo.cfg
> > 2017-08-20 07:16:22,819 [myid:] - INFO  [main:DatadirCleanupManager@78]
> -
> > autopurge.snapRetainCount set to 3
> > 2017-08-20 07:16:22,819 [myid:] - INFO  [main:DatadirCleanupManager@79]
> -
> > autopurge.purgeInterval set to 0
> > 2017-08-20 07:16:22,819 [myid:] - INFO  [main:DatadirCleanupManager@101]
> > -
> > Purge task is not scheduled.
> > 2017-08-20 07:16:22,822 [myid:] - WARN  [main:QuorumPeerMain@113] -
> > Either
> > no config or no quorum defined in config, running  in standalone mode
> > 2017-08-20 07:16:22,890 [myid:] - INFO  [main:QuorumPeerConfig@124] -
> > Reading configuration from: conf/zoo.cfg
> > 2017-08-20 07:16:22,891 [myid:] - INFO  [main:ZooKeeperServerMain@96] -
> > Starting server
> > 2017-08-20 07:16:22,900 [myid:] - INFO  [main:Environment@100] - Server
> > environment:zookeeper.version=3.4.9-1757313, built on 08/23/2016 06:50
> > GMT
> > 2017-08-20 07:16:22,901 [myid:] - INFO  [main:Environment@100] - Server
> > environment:host.name=kafka-1.node.rack1.consul
> > 2017-08-20 07:16:22,901 [myid:] - INFO  [main:Environment@100] - Server
> > environment:java.version=1.8.0_25
> > 2017-08-20 07:16:22,901 [myid:] - INFO  [main:Environment@100] - Server
> > environment:java.vendor=Oracle Corporation
> > 2017-08-20 07:16:22,901 [myid:] - INFO  [main:Environment@100] - Server
> > environment:java.home=/usr/java/jdk1.8.0_25/jre
> > 2017-08-20 07:16:22,901 [myid:] - INFO  [main:Environment@100] - Server
> > environment:java.class.path=zookeeper-3.4.9.jar:lib/log4j-
> > 1.2.16.jar:lib/slf4j-log4j12-1.6.1.jar:lib/slf4j-api-1.6.1.jar:conf
> > 2017-08-20 07:16:22,901 [myid:] - INFO  [main:Environment@100] - Server
> > environment:java.library.path=/usr/java/packages/lib/amd64:/
> > usr/lib64:/lib64:/lib:/usr/lib
> > 2017-08-20 07:16:22,901 [myid:] - INFO  [main:Environment@100] - Server
> > environment:java.io.tmpdir=/tmp
> > 2017-08-20 07:16:22,901 [myid:] - INFO  [main:Environment@100] - Server
> > environment:java.compiler=<NA>
> > 2017-08-20 07:16:22,902 [myid:] - INFO  [main:Environment@100] - Server
> > environment:os.name=Linux
> > 2017-08-20 07:16:22,902 [myid:] - INFO  [main:Environment@100] - Server
> > environment:os.arch=amd64
> > 2017-08-20 07:16:22,902 [myid:] - INFO  [main:Environment@100] - Server
> > environment:os.version=3.10.0-514.10.2.el7.x86_64
> > 2017-08-20 07:16:22,902 [myid:] - INFO  [main:Environment@100] - Server
> > environment:user.name=tetinstall
> > 2017-08-20 07:16:22,902 [myid:] - INFO  [main:Environment@100] - Server
> > environment:user.home=/home/tetinstall
> > 2017-08-20 07:16:22,903 [myid:] - INFO  [main:Environment@100] - Server
> > environment:user.dir=/opt/tetration/zookeeper/zookeeper-3.4.9
> > 2017-08-20 07:16:22,908 [myid:] - INFO  [main:ZooKeeperServer@815] -
> > tickTime set to 20000
> > 2017-08-20 07:16:22,908 [myid:] - INFO  [main:ZooKeeperServer@824] -
> > minSessionTimeout set to -1
> > 2017-08-20 07:16:22,908 [myid:] - INFO  [main:ZooKeeperServer@833] -
> > maxSessionTimeout set to -1
> > 2017-08-20 07:16:22,915 [myid:] - INFO  [main:NIOServerCnxnFactory@89] -
> > binding to port 0.0.0.0/0.0.0.0:2181
> > Killed
> >
> > --
> > Raghav
>



-- 
Raghav

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message