zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Hunt <ph...@apache.org>
Subject Re: Is SSL supported in 3.4.9?
Date Wed, 07 Dec 2016 16:15:38 GMT
Hi Dan. While Netty supports SSL I don't believe anyone worked through the
issues of what needed to change in ZK itself to get it to work until
3.5/ZOOKEEPER-2125. iow Netty was added in 3.4, however Netty+SSL was not
available until 3.5.

Patrick

On Wed, Dec 7, 2016 at 6:44 AM, Dan Langille <dan@langille.org> wrote:

> Hello,
>
> I'm getting mixed messages from the documentation, and I'm unable to get
> Zookeeper
> to talk on a secureClientPort.
>
> Is SSL supported in Zookeeper 3.4.9?
>
> At https://zookeeper.apache.org/doc/r3.4.9/zookeeperAdmin.html <
> https://zookeeper.apache.org/doc/r3.4.9/zookeeperAdmin.html> I see:
>
> "New in 3.4: Netty is an NIO based client/server communication
> framework.... Netty framework
> has built in support for encryption (SSL)...."
>
> But at https://cwiki.apache.org/confluence/display/ZOOKEEPER/
> ZooKeeper+SSL+User+Guide it
> states that SSL has "been added in ZOOKEEPER-2125", which is 3.5.1, 3.6.0
>
> If someone can confirm that SSL is indeed supported in 3.4.9, I'll keep
> debugging my configuration.
>
> Thank you.
>
> --
> Dan Langille - BSDCan / PGCon
> dan@langille.org
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message