zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Mantas <andremant...@gmail.com>
Subject Config options not being loaded?
Date Thu, 21 Jul 2016 02:28:26 GMT
Hi all.

I'm trying to experiment with some config options found in
https://zookeeper.apache.org/doc/r3.4.8/zookeeperAdmin.html#sc_configuration
but
they are not being loaded/used by the zookeeper server.

I've modified my config file 'zoo.cfg' to:

# The number of milliseconds of each tick
tickTime=2000
# The number of ticks that the initial
# synchronization phase can take
initLimit=10
# The number of ticks that can pass between
# sending a request and getting an acknowledgement
syncLimit=5
# the directory where the snapshot is stored.
# do not use /tmp for storage, /tmp here is just
# example sakes.
dataDir=/root/amantas/zookeeper-3.4.8/data
# the port at which the clients will connect
clientPort=2181
# Requires updates to be synced to media of the transaction log before
finishing processing the update.
# If this option is set to no, ZooKeeper will not require updates to be
synced to the media.
forceSync=no
# Skips ACL checks. This results in a boost in throughput, but opens up
full access to the data tree to everyone.
skipACL=yes
# The observers now log transaction and write snapshot to disk by default
like the participants.
# This reduces the recovery time of the observers on restart.
# Set to "false" to disable this feature. Default is "true"
syncEnabled=false
# ZooKeeper logs transactions to a transaction log.
# After snapCount transactions are written to a log file a snapshot is
started and a new transaction log file is created.
# The default snapCount is 100,000
snapCount=1000000

Then, restarted the zookeeper server:

~/amantas/zookeeper-3.4.8# ./bin/zkServer.sh stop
ZooKeeper JMX enabled by default
Using config: /root/amantas/zookeeper-3.4.8/bin/../conf/zoo.cfg
Stopping zookeeper ... STOPPED

~/amantas/zookeeper-3.4.8# ./bin/zkServer.sh start
ZooKeeper JMX enabled by default
Using config: /root/amantas/zookeeper-3.4.8/bin/../conf/zoo.cfg
Starting zookeeper ... STARTED

However, when listing the server configuration I don't see some of the
config params:

~/amantas/zookeeper-3.4.8# nc localhost 2181
conf
clientPort=2181
dataDir=/root/amantas/zookeeper-3.4.8/data/version-2
dataLogDir=/root/amantas/zookeeper-3.4.8/data/version-2
tickTime=2000
maxClientCnxns=60
minSessionTimeout=4000
maxSessionTimeout=40000
serverId=0

What am I doing wrong?

Thanks in advance!

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message