zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From s influxdb <elastic....@gmail.com>
Subject Re: node 2 not rejoining cluster
Date Thu, 07 Apr 2016 17:14:53 GMT
telnet works on 2888 and 3888 to the other nodes. Now i see
java.net.SocketTimeoutException: connect timed out messages in the logs for
node 2

On Thu, Apr 7, 2016 at 3:05 AM, Flavio Junqueira <fpj@apache.org> wrote:

> I only see notifications from the node to itself. It says that it is
> connected to 1, but it doesn't seem to be receiving the notification from
> 1. It also doesn't seem to be receiving the connection request from 3.
>
> Last time I've seen something like this was due to iptables rules, but if
> it was working before and no configuration has changed, then I don't know
> what it could be.
>
> -Flavio
>
> > On 07 Apr 2016, at 05:43, s influxdb <elastic.l.k@gmail.com> wrote:
> >
> > this is the pastie
> > http://pastie.org/10788301
> >
> > On Wed, Apr 6, 2016 at 9:41 PM, s influxdb <elastic.l.k@gmail.com>
> wrote:
> >
> >> We had one of the node giving OOM java.lang.OutOfMemoryError: unable to
> >> create new native thread and then being unresponsive.
> >>
> >> We tried to add the node back to the cluster but with no luck.
> >>
> >> It doesn't seem to "Receive any notification "  messages from the other
> >> nodes.
> >> Keeps "Sending notifications " in loop
> >>
> >> Please see attached the logs of the node that is out of rotation.
> >>
> >> Any inputs appreciated.
> >>
> >> Thanks
> >>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message