zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Cannot find version in repository
Date Sun, 03 Jan 2016 17:02:23 GMT
Was it possible that QuorumPeerMain didn't start ?

Please check the log.

Also use 'ps aux' and search for processes using java.

Cheers

On Sun, Jan 3, 2016 at 8:52 AM, sam mohel <sammohel5@gmail.com> wrote:

> thanks for your time , but it is an example not by process
> the result with me is just
>
> 1410 Jps
>
>
> but the example illustarte that i should got like this
> 1935 nimbus
> 1092 ElasticSearch
>  1982 core
>  1529 QuorumPeerMain
>
>
> BUT with different numbers
>
> On Sun, Jan 3, 2016 at 6:49 PM, Ted Yu <yuzhihong@gmail.com> wrote:
>
> > I assumed you downloaded 3.4.6 from:
> > https://archive.apache.org/dist/zookeeper/zookeeper-3.4.6/
> >
> > If you ran zkServer.sh from where 3.4.6 was stored locally, the version
> > would be 3.4.6
> >
> > Alternatively, doing 'ps aux | grep 1529' (the pid for QuorumPeerMain)
> > would show you the path.
> >
> > Cheers
> >
> > On Sun, Jan 3, 2016 at 8:34 AM, sam mohel <sammohel5@gmail.com> wrote:
> >
> > > thanks i installed now 3.4.6 and delete 3.4.7 but how can i know
> versoin
> > of
> > > running zookeeper ?
> > >
> > > i mean i'm now used ./zkServer.sh start
> > > and zookeeper ran , i want to know the verion of it to make sure that
> > it's
> > > 3.4.6 ?
> > >
> > > i noticed when i used jps after ran zookeeper i got
> > >
> > > 1410 Jps   only
> > >
> > > which it's supposed i got like
> > >
> > > 2129 Jps
> > >  991 NettyServer
> > >  1935 nimbus
> > >  1092 ElasticSearch
> > >  1982 core
> > >  1529 QuorumPeerMain
> > >
> > >
> > > On Sun, Jan 3, 2016 at 6:18 PM, Ted Yu <yuzhihong@gmail.com> wrote:
> > >
> > > > From https://github.com/apache/storm/blob/0.9.x-branch/pom.xml ,
> 3.4.6
> > > is
> > > > used.
> > > >
> > > > If you build Storm locally, it would download artifacts for 3.4.6
> into
> > > > local maven repository.
> > > >
> > > > What I meant in previous email was that 3.4.7 was not stable - see
> > > > ZOOKEEPER-2347
> > > >
> > > > Cheers
> > > >
> > > > On Sun, Jan 3, 2016 at 7:43 AM, sam mohel <sammohel5@gmail.com>
> wrote:
> > > >
> > > > > i'm sorry i didn't got what do you mean by the link , just i'm
> asking
> > > > that
> > > > > storm using in library folder version -3.3.3 and i installed 3.4.7
> or
> > > > > whatever version but in the repoisroty folder still read 3.3.3 so
i
> > > need
> > > > to
> > > > > add my version i installed
> > > > >
> > > > > On Sun, Jan 3, 2016 at 5:23 PM, Ted Yu <yuzhihong@gmail.com>
> wrote:
> > > > >
> > > > > > Please see this thread:
> > > > > >
> > > > > >
> > > http://search-hadoop.com/m/JhBoa1A4TJl1A62qq&subj=Re+Whither+ZK+3+4+6+
> > > > > >
> > > > > > Suggest switching to 3.4.6 before 3.4.8 comes out.
> > > > > >
> > > > > > FYI
> > > > > >
> > > > > > On Sun, Jan 3, 2016 at 5:23 AM, sam mohel <sammohel5@gmail.com>
> > > wrote:
> > > > > >
> > > > > > > <
> > > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
> http://stackoverflow.com/questions/34574276/cannot-find-version-in-repository#
> > > > > > > >
> > > > > > >
> > > > > > > I'm new to ubuntu also in zookeeper, I installed storm-0.9.0.1
> > with
> > > > > > > zookeeper-3.4.7
> > > > > > >
> > > > > > > But when i checked this path
> > > > > > >
> > > > > > > .m2/repository/org/apache/zookeeper/
> > > > > > >
> > > > > > > I found zookeeper version 3.3.3 I need to add my version
3.4.7
> > with
> > > > all
> > > > > > > files it need How can i add it ?
> > > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message