zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vikrant Singh <vikrant.subscr...@gmail.com>
Subject Re: QuorumPeerMain not listed in JPS
Date Wed, 27 Jan 2016 17:15:56 GMT
I faced this issue as well, but when I ran the same command with "sudo" it
listed the process. worth trying.
[vikrant@somebox ~]$ sudo jps -lm
27867 sun.tools.jps.Jps -lm
12046 org.apache.zookeeper.server.quorum.QuorumPeerMain
/home/y/conf/zookeeper/zookeeper.cfg
[vikrant@somebox~]$ jps -l
27883 sun.tools.jps.Jps
[vikrant@somebox ~]$


On Wed, Jan 27, 2016 at 7:21 AM, Ted Yu <yuzhihong@gmail.com> wrote:

> Have you tried using 'ps' command and searching for QuorumPeerMain ?
>
> Cheers
>
> On Wed, Jan 27, 2016 at 1:12 AM, deepakkhattar <deepak_khattar@hotmail.com
> >
> wrote:
>
> > Hi,
> >
> > I have setup 3 node zookeeper cluster, 1 leader and 2 follers start
> without
> > any issue. But jps is not listing Quorumpeermai. When I check server
> status
> > via
> > zkServer.sh status it works on all the nodes. Creation on znodes using
> > zkCli
> > is woring fine and is replicated to other node all
> >
> > Pleas suggest how to trouble shoot the issue.
> >
> > regards
> >
> > deepa
> >
> >
> >
> > --
> > View this message in context:
> >
> http://zookeeper-user.578899.n2.nabble.com/QuorumPeerMain-not-listed-in-JPS-tp7581949.html
> > Sent from the zookeeper-user mailing list archive at Nabble.com.
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message