zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Flavio Junqueira <fpjunque...@yahoo.com.INVALID>
Subject Re: Zookeeper version and SSL
Date Tue, 05 Jan 2016 12:08:19 GMT
Hi Christophe,

Releases of the 3.5 branch are still alpha and SSL support is only available in 3.5 and trunk,
so if you really need the feature, then you'd to go with 3.5.1-alpha.

-Flavio

> On 03 Jan 2016, at 23:38, Christophe Schmitz <christophe@instaclustr.com> wrote:
> 
> Hi there,
> 
> I would like to use Zookeeper, but I would need SSL support for
> client-server encryption.
> I found this nice tutorial:
> https://cwiki.apache.org/confluence/display/ZOOKEEPER/ZooKeeper+SSL+User+Guide
> And it reference JIRA zookeeper-2125
> https://issues.apache.org/jira/browse/ZOOKEEPER-2125 which is only fixed
> since zookeeper 3.5.1.
> 
> Zookeeper main webpage is listing 3.5.0 and 3.5.1 as 'alpha' version. On
> the other hand, the github project page has some git tags that seems stable
> (release-3.5.1).
> 
> So I am wondering if the github tagged version 3.5.1 can be considered
> stable at this stage, and if not, if there are some stable way to get ssl
> encryption between server and client with a stable version of Zookeeper.
> 
> Thanks!
> 
> Christophe


Mime
View raw message