zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Nauroth <cnaur...@hortonworks.com>
Subject Re: zkServer start under Windows
Date Sat, 05 Dec 2015 16:08:28 GMT
The zkServer.cmd (Windows) syntax is a bit different from the zkServer.sh
(Unix) syntax.  The cmd script doesn't support the
start/start-foreground/stop/etc. sub-commands of the shell script.
Instead, you just call "zkServer.cmd" without arguments, and it goes.

It wouldn't be correct to remove the %* from the end.  QuorumPeerMain is
designed to accept arguments, such as a configuration file location, so
omitting the command line arguments would prevent that.

This isn't necessarily a bug, but there is probably room for improvement
in the documentation.  We could use a section specifically describing
command usage differences on Windows.

--Chris Nauroth




On 12/5/15, 2:26 AM, "Flavio Junqueira" <fpjunqueira@yahoo.com.INVALID>
wrote:

>Hi Mello,
>
>Which version are you using? And yes, creating a jira sounds like the
>right course of action.
>
>Thanks,
>-Flavio
>
>> On 04 Dec 2015, at 18:53, Cesar Mello <cmello@gmail.com> wrote:
>> 
>> Hi,
>> 
>> I tried "zkServer start" under Windows and it doesn't seem to work. It
>> seems the "start" command line parameter should not be passed to
>> QuorumPeerMain, right? So I removed the "%*" from the end of the line in
>> zkServer.cmd:
>> 
>> call %JAVA% "-Dzookeeper.log.dir=%ZOO_LOG_DIR%"
>> "-Dzookeeper.root.logger=%ZOO_LOG4J_PROP%" -cp "%CLASSPATH%" %ZOOMAIN%
>> "%ZOOCFG%" %*
>> 
>> And it worked! Should I file this into the bug tracker?
>> 
>> Thank you for the attention.
>> 
>> Best regards
>> Mello
>
>


Mime
View raw message