zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Whither ZK 3.4.6?
Date Thu, 17 Dec 2015 21:53:46 GMT
I think ZOOKEEPER-2347 is the locking issue.

bq. we should keep older releases for a while

This is a good idea.

On Thu, Dec 17, 2015 at 1:51 PM, Michi Mutsuzaki <mutsuzaki@gmail.com>
wrote:

> for the future releases, maybe we should keep older releases for a
> while and have a 'zookeeper-stable' symlink to indicate the
> recommended version.
>
> steven, is there a jira for the locking issue?
>
> On Thu, Dec 17, 2015 at 1:38 PM, Flavio Junqueira <fpj@apache.org> wrote:
> > Raul is going to remove the references to 3.4.7 and will notify once it
> is done on the mailing list.
> >
> > -Flavio
> >
> >> On 17 Dec 2015, at 21:35, Ted Yu <yuzhihong@gmail.com> wrote:
> >>
> >> I wonder if 3.4.7 should be pulled from the mirrors, meanwhile 3.4.6
> >> re-populated until 3.4.8 comes out
> >>
> >> Cheers
> >>
> >> On Thu, Dec 17, 2015 at 1:30 PM, Steven Schlansker <
> >> sschlansker@opentable.com> wrote:
> >>
> >>>
> >>>
> >>>> On Dec 17, 2015, at 1:14 PM, Ted Yu <yuzhihong@gmail.com> wrote:
> >>>>
> >>>> It should be available here:
> >>>> https://archive.apache.org/dist/zookeeper/zookeeper-3.4.6/
> >>>
> >>> Yeah, did find that eventually. Thanks for the heads up.
> >>>
> >>> Still sucks that it's now on a single archive host instead of the
> mirror
> >>> network and changed location, breaking our configuration :/
> >>>
> >>>>
> >>>> FYI
> >>>>
> >>>> On Thu, Dec 17, 2015 at 1:07 PM, Steven Schlansker <
> >>>> stevenschlansker@gmail.com> wrote:
> >>>>
> >>>>> I've been following the mailing list and noticed that ZK 3.4.7
> >>> introduces a
> >>>>> serious locking bug and as such there is good reason not to upgrade.
> >>>>>
> >>>>> However, 3.4.6 seems to already have been pulled from the Apache
> >>> mirrors?
> >>>>>
> >>>>> [steven@Anesthetize:~]% curl -i
> >>>>>
> >>>
> http://apache.cs.utah.edu/zookeeper/zookeeper-3.4.6/zookeeper-3.4.6.tar.gz
> >>>>> HTTP/1.1 404 Not Found
> >>>>>
> >>>>> We use configuration management to ensure that all our nodes have
the
> >>> same
> >>>>> ZooKeeper version installed,
> >>>>> and now our previously working configuration has broken because
the
> >>> latest
> >>>>> working 3.4.x version has been
> >>>>> pulled from the mirrors.
> >>>>>
> >>>>> This is really unpleasant, hopefully you'd agree with me that this
> is an
> >>>>> unfriendly move
> >>>>> to purge it so quickly?
> >>>>>
> >>>>>
> >>>
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message