zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dean Voets <d...@motum.be>
Subject It appears the wrong File seperator is used when dynamicConfigFile in zoo.cfg changes. (in 3.5.1-alpha)
Date Fri, 06 Nov 2015 17:59:02 GMT
Hello,

This week I got to know ZooKeeper by working on the distributed planning system at work (in
automation of fork lifts). I upgraded the zookeeper version we use to the new 3.5.1 version
to support a changing fleet size using the dynamic reconfiguration in ZooKeeper.
During the initial tests on my development laptop (mac OS) everything worked nicely. Unfortunately
this changed when trying it on the embedded windows systems used in our vehicles. Soon after
starting the zookeeper servers, a version is added in the filename of the dynamic configuration
file specified in zoo.cfg. The updated location of the file is saved using \ as file seperator
instead of / causing FileNotFoundExceptions in QuorumPeerMain. 
I’ve been looking for the cause of this for a while now but I’m stuck so I hope someone
can point me in the right direction to find the problem. At this point I have no clue if this
is caused by a mistake in configuration from me (and what configuration that could cause this)
or if I should be looking at the zooKeeper classes for some windows specific bug (or which
class in zookeeper updates the zoo.cfg when the dynamic configuration changes).

Thanks in advance,
Dean Voets


Mime
View raw message