zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan Kelly <iv...@apache.org>
Subject Re: AIX support for zookeeper
Date Tue, 11 Aug 2015 08:17:28 GMT
Because, AFAIK, none of the developer have access to AIX hardware to
certify that it is supported. Nor is AIX widespread enough to justify
spending specific resources on testing it that could be spent elsewhere.

That said, the's no reason why it wouldn't work as long as there's a java
6+ jvm available. The only possible thing that may be linux specific are
the scripts (but they will have been tested on Mac OS X also no doubt).

The list of supported platforms is very out of date. Solaris is referred to
as *Sun* Solaris. FreeBSD is supported only on the client, because the NIO
selector is broken which should be fixed by now. I think windows is fully
supported now also. I needs to be updated.

I've created a JIRA to update this for later releases:
https://issues.apache.org/jira/browse/ZOOKEEPER-2243

-Ivan

On Tue, Aug 11, 2015 at 8:55 AM Mohan <s.mohaan@gmail.com> wrote:

> ​​Hi,
>
>    I see that AIX is not listed under the 'Supported Platforms' section in
> almost all the versions of zookeeper, say
>
> http://zookeeper.apache.org/doc/r3.4.6/zookeeperAdmin.html#sc_supportedPlatforms
>
>    Is there a specific reason?
>
> Thanks,
> Mohan
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message