zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Flavio Junqueira <fpjunque...@yahoo.com.INVALID>
Subject Re: problem with Running zookeeper C client on a virtual machine!
Date Fri, 03 Jul 2015 11:58:24 GMT
It sounds right that the client shouldn't exit and generate a connection loss event instead.
But, I don't understand why you're messing up with the system time, what is it that you're
trying to achieve?

-Flavio

> On 03 Jul 2015, at 09:49, Wangyinwen <wangyinwen@huawei.com> wrote:
> 
> Hi!
>  
> I run zookeeper C client on a virtual machine(zookeeper version: 3.4.6, OS: Win7),
when I roll back system time
> to an earlier time(e.g. current time is 11:56:56, I change system time to 11:56:30),
the client process will print a message
> "(0x4a4):ZOO_ERROR@handle_socket_error_msg@1723: <mailto:%22(0x4a4):ZOO_ERROR@handle_socket_error_msg@1723:>
Sock et [9.64.253.228:2181] zk retcode=-4, errno=32(Broken pipe): failed while receiving a
server response"
> then client process exit. I wander to see what reason may cause ZK client exit,
> and how can I make the client process don’t exit but just post a session timeout event!
>  
>  
> Thank you!
>  
>  
>  
>  
> 
> 王胤文 00171980
> 2012实验室-中央软件院-欧拉九部(分布式软件LAB)
> 手机:18857136398
> 座机:057163024
> 座位:杭州研究所Z9-3-B35R
> 分布式软件LAB技术沙龙:http://3ms.huawei.com/hi/group/2028451 <http://3ms.huawei.com/hi/group/2028451>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message