zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Montgomery <davidmontgom...@gmail.com>
Subject Re: cant connect to zookeeper on ec2
Date Sun, 24 May 2015 02:02:57 GMT
I am connecting from the monitor SG.  i even tried with a python client.
Monitor SG has access top all ports on the zk SG.

import zc.zk
>>> zk = zc.zk.ZooKeeper('10.146.4.247:2181')
No handlers could be found for logger "kazoo.client"
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File
"/usr/local/lib/python2.7/dist-packages/zc.zk-2.1.0-py2.7.egg/zc/zk/__init__.py",
line 180, in __init__
    raise FailedConnect(connection_string)
zc.zk.FailedConnect: 10.146.4.247:2181




All TCP TCP 0 - 65535 sg-38391c52 (monitor)
TCP    2181 sg-38391c52 (monitor) Custom TCP Rule
TCP 2182 0.0.0.0/0 Custom TCP Rule
TCP 2812 sg-38391c52 (monitor) Custom TCP Rule
TCP 0 - 65000 sg-0fad2662 (zookeeper)
SSH    TCP 22 0.0.0.0/0

Thanks

On Sun, May 24, 2015 at 4:57 AM, Michi Mutsuzaki <mutsuzaki@gmail.com>
wrote:

> Hi David,
>
> Could you post your security group setting? The fact that telnet times
> out seems to indicate that packets are being dropped. Does telnet work
> with any other ports?
>
> On Sat, May 23, 2015 at 7:58 AM, David Montgomery
> <davidmontgomery@gmail.com> wrote:
> > Hi,
> >
> > zookeeper is running on ec2 on a dedicated server.
> >
> > I am using private ip address
> >
> > I allowed access to port 2181 on the zk security group.  Yet I cant
> connect
> > from servers that have access via security groups.  This makes to sense
> to
> > me whatsoever.
> >
> > here is my server id
> > head /var/lib/zookeeper/myid
> > 1
> >
> >
> > Here is my zoo.cfg
> >
> > maxClientCnxns=50
> > tickTime=2000
> > initLimit=10
> > syncLimit=5
> > dataDir=/var/lib/zookeeper
> > clientPort=2181
> > server.1=10.146.4.247:2888:3888
> >
> > here is my hostname
> >
> > hostname -f
> > ip-10-146-4-247.ec2.internal
> > hostname
> > ip-10-146-4-247
> >
> >
> > So.....I time out.  Even telnet will not work when I open the telnet
> port.
> > telnet 10.146.4.247 2181
> > Trying 10.146.4.247...
> >
> >
> > But if I run telnet on the zk server it works
> > telnet 10.146.4.247 2181
> > Trying 10.146.4.247...
> > Connected to 10.146.4.247.
> > Escape character is '^]'.
> >
> > I even tried standalone by removing server.1=10.146.4.247:2888:3888 from
> > zoo.cgf
> >
> > I installed on ubuntu 14.04 using cdh 5 apt-get install zookeeper-server
> >
> > I have no issues when I use digital ocean.  Why is aws soooo difficult?
> > How do I start unsing zookeeper on aws?
> >
> > Thanks
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message