zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raúl Gutiérrez Segalés <...@itevenworks.net>
Subject Re: Zookeeper Java Version Question
Date Sun, 05 Apr 2015 01:55:53 GMT
On 2 April 2015 at 17:20, Raúl Gutiérrez Segalés <rgs@itevenworks.net>
wrote:

> Hi,
>
> On 2 April 2015 at 13:00, Moore, Jason <Jason.Moore2@bestbuy.com> wrote:
>
>> Hi all,
>>
>> Is Zookeeper 3.4.5 or later compatible with java 8 runtime environment?
>>
>
> I haven't tried it myself, but by quick look at:
>
>
> http://www.oracle.com/technetwork/java/javase/8-compatibility-guide-2156366.html#A999198
>
> it seems there might be a few things (i.e.: modify the local security
> policy to be able to bind ports outside of the ephemeral range).
>

Actually - I take that back, I've been using it for development on my
fedora 21 laptop just fine:

~ ✔ java -version
Picked up JAVA_TOOL_OPTIONS: -Dfile.encoding=utf8
openjdk version "1.8.0_40"
OpenJDK Runtime Environment (build 1.8.0_40-b25)
OpenJDK 64-Bit Server VM (build 25.40-b25, mixed mode)

Not sure about any surprises in prod, though.


-rgs

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message