zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Conroy <ccon...@squareup.com>
Subject Re: Status of critical looped NPE issue?
Date Wed, 15 Apr 2015 20:42:04 GMT
I was able to get a stack dump from a user that experienced this problem,
and I've added it to the issue.

On Tue, Mar 3, 2015 at 2:52 PM, Camille Fournier <camille@apache.org> wrote:

> If you're seeing it then it is an issue. I don't really know about the
> status of 1504, not sure if it is relevant to this directly or not but we
> should make sure the thing that fixes this bug is merged in whether or not
> 1504 is done.
>
> Thanks,
> C
>
> On Tue, Mar 3, 2015 at 2:48 PM, Chris Conroy <cconroy@squareup.com> wrote:
>
> > On Tue, Mar 3, 2015 at 2:36 PM, Camille Fournier <camille@apache.org>
> > wrote:
> >
> > > Is there any more info you want to provide the ticket to help debug it
> in
> > > 3.4.6? There are some things that seem like they might be
> > solaris-specific.
> > > May of us have dev laptops with OSX so perhaps we can debug it there,
> > but I
> > > don't know how many folks have access to a solaris system to do
> > > system-specific debugging.
> > >
> >
> > I will try to get a stack trace and another sample log. I haven't been
> able
> > to reproduce it myself, but we have a lot of reports of it occurring on
> > OSX.
> >
> > So, I take it the issue is *not* believed to be fixed by the original
> patch
> > to the other issue?
> >
> >
> > >
> > > Thanks,
> > > C
> > >
> > >
> > > On Tue, Mar 3, 2015 at 2:22 PM, Chris Conroy <cconroy@squareup.com>
> > wrote:
> > >
> > > > ZOOKEEPER-1043 <http://zookeeper-1043/> is a critical issue (if
a
> > server
> > >
> >
> > Woops, incorrect lnk: fixed
> > https://issues.apache.org/jira/browse/ZOOKEEPER-1043
> >
> >
> > > > gets into this state it pegs the CPU spinning in an infinite NPE
> loop).
> > > > Yet, it is unassigned and unresolved. I commented on the issue and
> > tried
> > > > asking in IRC but got no response.
> > > >
> > > > On Sep 23 2014, a comment
> > > > <
> > > >
> > >
> >
> https://issues.apache.org/jira/browse/ZOOKEEPER-1043?focusedCommentId=14144036&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-14144036
> > > > >
> > > > indicated
> > > > that another issue has been fixed and merged and that this issue may
> > have
> > > > been fixed by ZOOKEEPER-1504
> > > > <https://issues.apache.org/jira/browse/ZOOKEEPER-1504>. However,
> that
> > > > issue
> > > > has been subsequently reopened.
> > > >
> > > >
> > > > What is the real status of this issue?
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message