zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Flavio Junqueira <fpjunque...@yahoo.com.INVALID>
Subject Re: New Zookeeper Installation - connection refused
Date Tue, 03 Feb 2015 21:19:06 GMT
The way you're setting the ports makes it look like you're trying to run 5 servers on the same
machine. Is it what you're trying to do and if so are you running the start script 5 times?
Could you post a sample of the exceptions you're seeing in any case?

-Flavio

> On 03 Feb 2015, at 18:46, penguin <barry.barnett@wellsfargo.com> wrote:
> 
> I have installed an instance of Zookeeper (v3.4.6) on 5 different servers
> (Linux).  I have created my zoo.cfg file and listed the servers as follows:
> 
> server.1=hostname1:2888:3888
> server.2=hostname2:2889:3889
> server.3=hostname3:2890:3890
> server.4=hostname4:2891:3891
> server.5=hostname5:2892:3892
> 
> I have put this on each server in the conf directory.
> 
> When I startup the server on each using zkServer.sh start, and I look in
> zookeeper.out, I see that zookeeper tries to connect, but the connection is
> refused for each attempt to connect to any of the servers.
> 
> When I issue zkServer.sh status:
> $ ./zkServer.sh status
> JMX enabled by default
> Using config: /opt/apps/current/bin/../conf/zoo.cfg
> Error contacting service. It is probably not running.
> 
> This happens on all 5 servers.  Any idea what I'm missing.  I also have my
> myid file for each, starting with '1' on the first, '2' on the second,
> etc...
> 
> 
> 
> 
> 
> 
> --
> View this message in context: http://zookeeper-user.578899.n2.nabble.com/New-Zookeeper-Installation-connection-refused-tp7580825.html
> Sent from the zookeeper-user mailing list archive at Nabble.com.


Mime
View raw message