zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From penguin <barry.barn...@wellsfargo.com>
Subject RE: New Zookeeper Installation - connection refused
Date Wed, 04 Feb 2015 15:51:20 GMT
$ nc -v remotehostname 2181
nc: connect to remotehostname port 2181 (tcp) failed: Connection refused

Regards,

Barry

From: Ludwig Pummer [via zookeeper-user] [mailto:ml-node+s578899n7580835h33@n2.nabble.com]
Sent: Wednesday, February 04, 2015 10:45 AM
To: Barnett, Barry F
Subject: Re: New Zookeeper Installation - connection refused

At this point, I would eliminate ZooKeeper from the equation and see if
you can talk to each other on the ZK ports using something primitive
like netcat.

On hostname1, nc -v -l 2181
On hostname2, nc -v hostname1 2181

Repeat with 2888, 3888 or whatever ports you give in the zoo.cfg for
each host and for each host as the listening server. If you get
Connection Refused, then you have something like a firewall blocking
your ports. If you don't, then the issue is with ZK. Try running a
standalone ZK and connecting with just zkCli.sh to port 2181. Then move
up to a 3-server quorum and then 5.

On 2/4/2015 7:31 AM, penguin wrote:

> No firewalls involved.  When I tried the zkCli.sh server hostname:port from one server
to another, I got connection refused SASL authentication (unknown error).  Any ideas as to
if something is configured incorrectly with some type of authentication?
>
> Regards,
>
> Barry
>
> From: Flavio Junqueira-2 [via zookeeper-user] [mailto:[hidden email]</user/SendEmail.jtp?type=node&node=7580835&i=0>]
> Sent: Wednesday, February 04, 2015 8:35 AM
> To: Barnett, Barry F
> Subject: Re: New Zookeeper Installation - connection refused
>
> I'm assuming you're seeing those messages in all servers. Those messages indicate that
the servers aren't being able to connect to each other to elect a leader. Could you make sure
you don't any kind of filtering, like a firewall, preventing those servers from talking to
each other.
> I'd also suggest to start with an ensemble of 3 servers, and starting only two initially
to debug.
> -Flavio
>
>       On Wednesday, February 4, 2015 12:52 PM, penguin <[hidden email]</user/SendEmail.jtp?type=node&node=7580833&i=0>>
wrote:
>
>
>
>   2015-02-03 12:31:58,118 [myid:1] - INFO  [QuorumPeer[myid=1]/0.0.0.0:2181:FastLeaderElection@815]
- New election. My id =  1, proposed zxid=0x02015-02-03 12:31:58,120 [myid:1] - INFO  [WorkerReceiver[myid=1]:FastLeaderElection@597]
- Notification: 1 (message format version), 1 (n.leader), 0x0 (n.zxid), 0x1 (n.round), LOOKING
(n.state), 1 (n.sid), 0x0 (n.peerEpoch) LOOKING (my state)2015-02-03 12:31:58,123 [myid:1]
- WARN  [WorkerSender[myid=1]:QuorumCnxManager@382] - Cannot open channel to 2 at election
address hostname.xxxx.com/IPadress here:3889java.net.ConnectException: Connection refused
>          at java.net.PlainSocketImpl.socketConnect(Native Method)        at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
       at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
       at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)     
  at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
>          at java.net.Socket.connect(Socket.java:579)
>
> This same message appears as it tries to connect to all the other servers over and over.
>
>
> Regards,
>
> Barry
>
> From: Flavio Junqueira-2 [via zookeeper-user] [mailto:[hidden email]</user/SendEmail.jtp?type=node&node=7580833&i=1>]
> Sent: Wednesday, February 04, 2015 4:27 AM
> To: Barnett, Barry F
> Subject: Re: New Zookeeper Installation - connection refused
>
> Hi Barry,
> I get that you have tried to anonymize the host names, but not using the same ports is
what I'd do if I were to run locally. To run across machines, I'd use the same ports to keep
the utilization of ports uniform across machines. It isn't strictly wrong to do the way you're
doing, though.
> If you still need help, you'll need to provide some more detail on what you're seeing
in your logs.
> -Flavio
>
>      On Wednesday, February 4, 2015 3:59 AM, Ibrahim El-sanosi (PGR) <[hidden email]</user/SendEmail.jtp?type=node&node=7580830&i=0>>
wrote:
>
>
>
>   If you want to run ZK in five machines, then you should list the servers in zoo.cfg
file  as follows:
>
> server.1=host1:2888:3888
> server.2=host2:2888:3888
> server.3=host3:2888:3888
> server.4=host4:2888:3888
> server.5=host5:2888:3888
>
> You should change the host name with the name of your machines or IPs (for each 5 machines),
and leave the ports the same. This how I do when I run 5 ZK servers.
>
> Ibrahim
>
> -----Original Message-----
> From: penguin [mailto:[hidden email]</user/SendEmail.jtp?type=node&node=7580830&i=1>]
> Sent: Tuesday, February 03, 2015 06:47 م
> To: [hidden email]</user/SendEmail.jtp?type=node&node=7580830&i=2>
> Subject: New Zookeeper Installation - connection refused
>
> I have installed an instance of Zookeeper (v3.4.6) on 5 different servers (Linux).  I
have created my zoo.cfg file and listed the servers as follows:
>
> server.1=hostname1:2888:3888
> server.2=hostname2:2889:3889
> server.3=hostname3:2890:3890
> server.4=hostname4:2891:3891
> server.5=hostname5:2892:3892
>
> I have put this on each server in the conf directory.
>
> When I startup the server on each using zkServer.sh start, and I look in zookeeper.out,
I see that zookeeper tries to connect, but the connection is refused for each attempt to connect
to any of the servers.
>
> When I issue zkServer.sh status:
> $ ./zkServer.sh status
> JMX enabled by default
> Using config: /opt/apps/current/bin/../conf/zoo.cfg
> Error contacting service. It is probably not running.
>
> This happens on all 5 servers.  Any idea what I'm missing.  I also have my myid file
for each, starting with '1' on the first, '2' on the second, etc...
>
>
> --
> View this message in context: http://zookeeper-user.578899.n2.nabble.com/New-Zookeeper-Installation-connection-refused-tp7580825p7580834.html
> Sent from the zookeeper-user mailing list archive at Nabble.com.
>


________________________________
If you reply to this email, your message will be added to the discussion below:
http://zookeeper-user.578899.n2.nabble.com/New-Zookeeper-Installation-connection-refused-tp7580825p7580835.html
To unsubscribe from New Zookeeper Installation - connection refused, click here<http://zookeeper-user.578899.n2.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_by_code&node=7580825&code=YmFycnkuYmFybmV0dEB3ZWxsc2ZhcmdvLmNvbXw3NTgwODI1fC0xNDYzMjU3NTMx>.
NAML<http://zookeeper-user.578899.n2.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>




--
View this message in context: http://zookeeper-user.578899.n2.nabble.com/New-Zookeeper-Installation-connection-refused-tp7580825p7580837.html
Sent from the zookeeper-user mailing list archive at Nabble.com.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message