zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Savvas Andreas Moysidis <savvas.andreas.moysi...@gmail.com>
Subject Syntax error: "(" unexpected (expecting "fi")
Date Thu, 15 Jan 2015 16:15:29 GMT
Hello There,

I have downloaded the latest Zookeeper file but when I try to run this
using the following command:
temp-dev/zookeeper-3.4.6/bin$ sh zkServer.sh start

I am getting the following error:
zkServer.sh: 81: /home/javadev/temp-dev/zookeeper-3.4.6/bin/zkEnv.sh:
Syntax error: "(" unexpected (expecting "fi")

I've seen a number of threads (
https://issues.apache.org/jira/browse/ZOOKEEPER-1937) all suggesting to
change the shebang to #!/bin/bash but that doesn't seem to work (still
gives the same error).

Some info about the environment I'm using:

Running lsb_release -s -d prints:
Ubuntu 14.04.1 LTS

and running java -version prints:
java version "1.8.0_25"

Any ideas?

Thanks,
Savvas

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message