zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Hunt <ph...@apache.org>
Subject Re: Make JDK 7 the minimum support version
Date Fri, 12 Dec 2014 23:53:17 GMT
+1 Makes sense to me.

I'm assuming we're talking 3.5+ here, right? We would continue to
support jdk6 in 3.4?

Patrick

On Fri, Dec 12, 2014 at 3:42 PM, Flavio Junqueira
<fpjunqueira@yahoo.com.invalid> wrote:
> +1 for supporting only 7 or later.
>
>
>> On 12 Dec 2014, at 21:28, Hongchao Deng <hdeng@cloudera.com> wrote:
>>
>> Hi all,
>>
>> I have been working on Netty + SSL and one of the changes I do is change
>> outgoingQueue to be LinkedBlockingDeque, which requires JDK 6.
>>
>> As Flavio (fpj) and Patrick (phunt) suggested, there are JIRAs discussing
>> JDK7: ZOOKEEPER-2046, ZOOKEEPER-1963. It seems many people are interested
>> in an upgrade to JDK 7.
>>
>> As we know, JDK 6 stops public updates. Making JDK 7 the minimum of
>> ZooKeeper going forward will drive us up-to-date and less work on
>> supporting older versions of JDK.
>>
>> I am raising this topic here to gather public responses. The question is
>> simple: should we make JDK 7 the minimum support version? Your advice,
>> ideas, suggestions are highly welcome and appreciated!
>>
>> --
>> *- Hongchao Deng*
>> *Software Engineer*
>

Mime
View raw message