zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rakesh R <rake...@huawei.com>
Subject RE: I got a problem when delete node
Date Tue, 22 Apr 2014 04:42:04 GMT
Hi Crystal,

Could you tell the reason why the ZooKeeper server hangs ? Also, how long it took to reform
the ZooKeeper quorum ?

>>>>>>> I have set timeout 1 min
Do you mean ZK session timeout ?

Since it lost quorum, I hope in your case the client might have received the KeeperException.ConnectionLossException
when performing the delete operation. 
Probably when performing the create znode operation it was able to send the request to a stable
ZK quorum.

FYI: ZK client behavior is, it won't retry the operation on failure. Application can observe
the "ZKConnection Watches" and write their own logic to retry it.

-Rakesh

-----Original Message-----
From: crystal [mailto:xuange1106@gmail.com] 
Sent: 22 April 2014 08:11
To: zookeeper-user@hadoop.apache.org
Subject: I got a problem when delete node

Hi,
I started to learn zookeeper recently. Now I got a problem when using java client to delete
zk node.
Description:
Use zookeeper java client to delete a node which already exist. like zk.delete(path,-1). I
have set timeout 1 min. But the zookeeper server seems to be hung up. the zk server state
change to connecting, and I cannot reconnect it anymore. 1 min later , I got a exception "
EndOfStreamException: Unable to read additional data from client". But no problem when I create
a new node.

Regards,
Crystal



--
View this message in context: http://zookeeper-user.578899.n2.nabble.com/I-got-a-problem-when-delete-node-tp7579794.html
Sent from the zookeeper-user mailing list archive at Nabble.com.

Mime
View raw message