zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Hunt <ph...@apache.org>
Subject Re: Staggered start of nodes in an ensemble
Date Tue, 12 Nov 2013 05:26:46 GMT
Probably goes without saying but you cleared out the datadir when
switching from 3.5 to 3.4? I don't think anyone has tested 3.4 code
reading a datadir generated by a 3.5 server yet....

Patrick

On Mon, Nov 11, 2013 at 9:19 PM, Patrick Hunt <phunt@apache.org> wrote:
> You are using the same configuration on all three nodes, is that
> right? Permissions for the dataDir are set properly on all three?
>
> Have you verified that the "myid" file is correct, and corresponds
> correctly, to each of the 3 servers? (.193 should have myid of 1, .194
> myid of 2, .195 myid of 3)
>
> I'd also suggest that you use 20 & 10 as the init and sync limits respectively.
>
> Patrick
>
> On Mon, Nov 11, 2013 at 9:09 PM, Arindam Mukherjee
> <arindam.mukerjee@gmail.com> wrote:
>> On Tue, Nov 12, 2013 at 8:43 AM, kishore g <g.kishore@gmail.com> wrote:
>>> can you provide the configurations (zoo.cfg) on each server. From the
>>> description, your server 1 seems to be incorrectly configured.
>>>
>>
>> This is the configuration:
>>
>> tickTime=2000
>> dataDir=/var/zookeeper
>> initLimit=5
>> syncLimit=2
>> clientPort=2181
>> server.1=172.31.68.193:2888:3888
>> server.2=172.31.68.194:2888:3888
>> server.3=172.31.68.195:2888:3888
>>
>> Thanks.

Mime
View raw message