zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Tarbox <briantar...@gmail.com>
Subject Server seems not to be sending keep-alives so I lose my session ("have not heard from server....")
Date Mon, 25 Feb 2013 16:51:40 GMT
I am getting the dreaded message:

 10:59:45,871 INFO [org.apache.zookeeper.ClientCnxn] - <Client session
timed out, have not heard from server in 31482ms for sessionid
0x13d11dd08160007, closing socket connection and attempting reconnect>

and from looking at the logs it certainly seems that the keep alive
messages are sometime just not being sent.

In my case I see a bunch of these:
10:58:00,164 DEBUG [org.apache.zookeeper.ClientCnxn] - <Got ping response
for sessionid: 0x13d11dd08160007 after 0ms>
10:58:13,511 DEBUG [org.apache.zookeeper.ClientCnxn] - <Got ping response
for sessionid: 0x13d11dd08160007 after 0ms>
10:58:26,857 DEBUG [org.apache.zookeeper.ClientCnxn] - <Got ping response
for sessionid: 0x13d11dd08160007 after 0ms>
10:58:40,205 DEBUG [org.apache.zookeeper.ClientCnxn] - <Got ping response
for sessionid: 0x13d11dd08160007 after 0ms>
10:59:14,140 DEBUG [org.apache.zookeeper.ClientCnxn] - <Got ping response
for sessionid: 0x13d11dd08160007 after 0ms>

But then nothing from 10:59:14 until 10:59:45 when my client decides its
been too long and so times out.

I'm running 3.4.5 on EC2 ...any suggestions welcome.

Thanks.

Brian Tarbox
-- 
http://about.me/BrianTarbox

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message