zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Cabrera <l...@toolazydogs.com>
Subject Re: Kazoo 0.8: Queue Timeout warnings
Date Mon, 10 Dec 2012 01:47:45 GMT
Well, it is a ping, and the pings are sent out when the queue has been empty for a long time.

You will note that these are not warning messages but simple debug messages.  HTH.


Regards,
Alan

On Dec 9, 2012, at 5:30 PM, Matt Wise wrote:

> Interesting ... its too bad the wording is unclear. At least its nothing though, thanks!
> 
> --Matt
> 
> On Dec 9, 2012, at 4:18 PM, Alan Cabrera <list@toolazydogs.com> wrote:
> 
>> 
>> On Dec 9, 2012, at 11:58 AM, Matt Wise wrote:
>> 
>>> Using Kazoo 0.8 and ZooKeeper 3.4.5 I am seeing these warning messages when I
have DEBUG logging turned on. Are they normal?
>>> 
>>>> zk_watcher[kazoo.protocol.connection-140107313350400-reader: (DEBUG) Received
PING
>>>> zk_watcher[kazoo.protocol.connection-140107323893504-_send_request: (DEBUG)
Queue timeout.  Sending PING
>>>> zk_watcher[kazoo.protocol.connection-140107313350400-reader: (DEBUG) Received
PING
>>>> zk_watcher[kazoo.protocol.connection-140107323893504-_send_request: (DEBUG)
Queue timeout.  Sending PING
>>>> zk_watcher[kazoo.protocol.connection-140107313350400-reader: (DEBUG) Received
PING
>> 
>> 
>> These are quite normal.  If your client is not sending any commands to the Zookeeper
cluster the Kazoo client needs to send pings to the cluster so that the cluster knows that
your client is still around.
>> 
>> 
>> Regards,
>> Alan
>> 
> 


Mime
View raw message