zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From yang.li <yang...@baifendian.com>
Subject Some thing is wrong
Date Wed, 17 Oct 2012 06:06:21 GMT

Hi, all:
     
I'm in charge of a zookeeper cluster including six nodes. It worked well for the last six
months,
but yesterday when I want to list the children of a specific path "/dp/monitor_root/child/CDSkafkaSensor/msg",

something is just wrong. Here is the dump info as shown below:

[zk: zk-6:2181(CONNECTED) 1] ls /dp/monitor_root/child/CDSkafkaSensor/msg
2012-10-17 13:47:28,719 [myid:] - WARN  [main-SendThread(m32p118.bfdabc.com:2181):ClientCnxn$SendThread@1057]
- Session 0x63a6d4272590001 for server m32p118.bfdabc.com/192.168.32.118:2181, unexpected
error, closing socket connection and attempting reconnect
java.io.IOException: Packet len5362775 is out of range!
        at org.apache.zookeeper.ClientCnxnSocket.readLength(ClientCnxnSocket.java:112)
        at org.apache.zookeeper.ClientCnxnSocketNIO.doIO(ClientCnxnSocketNIO.java:77)
        at org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:291)
        at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1035)

WATCHER::

WatchedEvent state:Disconnected type:None path:null
Exception in thread "main" org.apache.zookeeper.KeeperException$ConnectionLossException: KeeperErrorCode
= ConnectionLoss for /dp/monitor_root/child/CDSkafkaSensor/msg
        at org.apache.zookeeper.KeeperException.create(KeeperException.java:99)
        at org.apache.zookeeper.KeeperException.create(KeeperException.java:51)
        at org.apache.zookeeper.ZooKeeper.getChildren(ZooKeeper.java:1448)
        at org.apache.zookeeper.ZooKeeper.getChildren(ZooKeeper.java:1476)
        at org.apache.zookeeper.ZooKeeperMain.processZKCmd(ZooKeeperMain.java:717)
        at org.apache.zookeeper.ZooKeeperMain.processCmd(ZooKeeperMain.java:593)
        at org.apache.zookeeper.ZooKeeperMain.executeLine(ZooKeeperMain.java:365)
        at org.apache.zookeeper.ZooKeeperMain.run(ZooKeeperMain.java:323)
        at org.apache.zookeeper.ZooKeeperMain.main(ZooKeeperMain.java:282)

I have tried many ways to solve this problem, but none of those works,  even the "super user"
method.
Now neither can I list the node, nor can I delete it . So I really really need a help. Thank
you!



yang.li
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message