zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From harry <harry.a...@gmail.com>
Subject Unable to run the SyncPrimitive test program
Date Wed, 08 Aug 2012 00:24:11 GMT
Hi,
I am new to zookeeper. I copied the SyncPrimitive.java code from the
zookeeper tutorial (
http://zookeeper.apache.org/doc/r3.3.2/zookeeperTutorial.html)  and tried to
run the producer using the following option
/  java -cp "$ZOOKEEPER_LIB" syncPrimitive qTest localhost:2181 1000 p/
This ran well and exited after it was able to produce the 1000 keys under
the app1. i can see that it created the values under /app1  using the
zkCli.sh script.
Then i tried to run the consumer with the following option.
 / java -cp "$ZOOKEEPER_LIB" syncPrimitive qTest localhost:2181 1000 c/
This program seems to run in in infinite loop by printing this...

/Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0
Temporary value: /app1/element0/

I am not sure what might be the issue. Any help is really appreciated.
Btw i have 3 VM's running the zookeeper servers. Here is my zoo.conf 


tickTime=2000
dataDir=/home/lsadm/hnath/zookeeper-3.4.4/data
clientPort=2181
initLimit=5
syncLimit=2
server.1=10.22.1.2:2888:3888
server.2=10.22.1.26:2888:3888
server.3=10.22.1.28:2888:3888

Thanks
Harry



--
View this message in context: http://zookeeper-user.578899.n2.nabble.com/Unable-to-run-the-SyncPrimitive-test-program-tp7577787.html
Sent from the zookeeper-user mailing list archive at Nabble.com.

Mime
View raw message