zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Nickerson <davidnickerson4mailingli...@gmail.com>
Subject How to Build ZooKeeper
Date Tue, 17 Jul 2012 16:31:44 GMT
I have a scenario in which I need to run an embedded ZooKeeper server. (For
customer convenience, mostly.) However, if the ZooKeeper server fails, it
shouldn't call System.exit. There is a patch, but it has not been
committed.<https://issues.apache.org/jira/browse/ZOOKEEPER-575> I
plan to use the patch for reference and modify ZooKeeper 3.3.5.

I got the source code of ZooKeeper 3.3.5 using SVN and Eclipse, I selected
the output folder as something other than 'bin', and I ran the build script
with the targets compile, compile-test, and eclipse.The build fails and
gives this output. <http://pastebin.com/wFERRWiJ>

I'm not sure whether it's failing because it's trying to
execute workspace\ZooKeeper or because the "target release 1.5 conflicts
with default source release 1.7".

I will post a link showing my configuration in a second e-mail. I had to
reduce the number of links to get past the spam filter.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message