zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Burger <tvbur...@gmail.com>
Subject Constructor parameter sessionTimeout of class ZooKeeper can't be 0
Date Thu, 09 Feb 2012 13:44:41 GMT
Hi all,

I just figured out that if you enter 0 as 'requested' sessionTimeout in the
constructor that the client won't send valid data to the server...

I'm using version 3.3.4 of zookeeper.

2012-02-09 14:14:51,178 - INFO  [NIOServerCxn.Factory:
0.0.0.0/0.0.0.0:2181:NIOServerCnxn$Factory@251] - Accepted socket
connection from /127.0.0.1:59964
2012-02-09 14:14:51,179 - WARN  [NIOServerCxn.Factory:
0.0.0.0/0.0.0.0:2181:NIOServerCnxn@634] - EndOfStreamException: Unable to
read additional data from client sessionid 0x0, likely client has closed
socket
2012-02-09 14:14:51,180 - INFO  [NIOServerCxn.Factory:
0.0.0.0/0.0.0.0:2181:NIOServerCnxn@1435] - Closed socket connection for
client /127.0.0.1:59964 (no session established for client)
2012-02-09 14:14:52,817 - INFO  [NIOServerCxn.Factory:
0.0.0.0/0.0.0.0:2181:NIOServerCnxn$Factory@251] - Accepted socket
connection from /127.0.0.1:59965
2012-02-09 14:14:52,818 - WARN  [NIOServerCxn.Factory:
0.0.0.0/0.0.0.0:2181:NIOServerCnxn@634] - EndOfStreamException: Unable to
read additional data from client sessionid 0x0, likely client has closed
socket
2012-02-09 14:14:52,819 - INFO  [NIOServerCxn.Factory:
0.0.0.0/0.0.0.0:2181:NIOServerCnxn@1435] - Closed socket connection for
client /127.0.0.1:59965 (no session established for client)
2012-02-09 14:14:54,490 - INFO  [NIOServerCxn.Factory:
0.0.0.0/0.0.0.0:2181:NIOServerCnxn$Factory@251] - Accepted socket
connection from /127.0.0.1:59966
2012-02-09 14:14:54,490 - WARN  [NIOServerCxn.Factory:
0.0.0.0/0.0.0.0:2181:NIOServerCnxn@634] - EndOfStreamException: Unable to
read additional data from client sessionid 0x0, likely client has closed
socket
2012-02-09 14:14:54,491 - INFO  [NIOServerCxn.Factory:
0.0.0.0/0.0.0.0:2181:NIOServerCnxn@1435] - Closed socket connection for
client /127.0.0.1:59966 (no session established for client)

Is this a bug or a feature?

Regards, Tom

-- 
Tom Burger | tvburger@gmail.com | +31 (0)62 412 20 27
http://www.linkedin.com/in/tvburger

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message