zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Hunt <ph...@apache.org>
Subject Re: connection lost
Date Mon, 19 Dec 2011 18:29:49 GMT
fyi That linger change was included in 3.3.4 and 3.4.1.

Patrick

On Mon, Dec 19, 2011 at 8:44 AM, Benjamin Reed <breed@apache.org> wrote:
> which version of the server are you using. this sounds like the linger
> bug that was fixed a while back.
>
> ben
>
> On Sun, Dec 18, 2011 at 6:22 PM, Camille Fournier <camille@apache.org> wrote:
>> That is not what we would expect from the cluster. What do the server logs show?
>>
>> On Sun, Dec 18, 2011 at 9:13 PM, 朱晨杰 <zcj0429@gmail.com> wrote:
>>> Hi, everyone:
>>>   I'm now using Zookeeper as my service server. There are 3 Zookeeper
>>> servers, then I use 3 pc connect to them. On each pc there are 20 processes
>>> connect to zookeeper cluster so there are totally 60 connection. I
>>> terminate 20 processes on one pc simultaneously, then I find the status of
>>> all the 60 connection  turned to "disconnected". After a while, the living
>>> 40 process start re-connect to zookeeper, but they all become "expired". I
>>> thought the connetion of one client would not affect others, but the result
>>> shows it does affect.
>>>   So I want to ask: Does it cost a lot for zookeeper to deal with a lost
>>> connnetion? And if too much connection lost at the same time will cause
>>> zookeeper deny of service?
>>>   Thanks!
>>> --
>>> Zhu Chenjie
>>> Zhejiang University, China

Mime
View raw message