zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Dunning <ted.dunn...@gmail.com>
Subject Re: Zookeeper Memory Leak?
Date Wed, 14 Sep 2011 18:59:47 GMT
OK.

And how much memory do you have on the machine?  How much memory did you
allocate to each of the Zookeeper servers you are running?  What else is on
the machine?  What language are you calling Zookeeper from (I assume Java
from your comment about a POJO)?

Is there any way that you can run the three Zookeeper servers on separate
machines?  That would let you use the default configuration and would
simplify debugging your configuration issue.

Finally, are you sure of the size of the data that you are writing to
Zookeeper?  That is a long shot, but it wouldn't hurt to print out the size
of the byte array that you are writing to make sure it isn't growing by some
odd circumstance.

On Wed, Sep 14, 2011 at 3:06 PM, Xuehan Xu <xxhdx1985126@gmail.com> wrote:

> I constructed under the "zookeeper" node  an EPHEMERAL node representing my
> PC, and store the usage information of cpu, memory and hard disk in the
> form
> of a POJO as the data of the node which is refreshed every two seconds
>
> On 14 September 2011 20:25, Ted Dunning <ted.dunning@gmail.com> wrote:
>
> > What kind of data are you storing on the Zookeeper servers?
> >
> > On Wed, Sep 14, 2011 at 6:34 AM, Xuehan Xu <xxhdx1985126@gmail.com>
> wrote:
> >
> > > Dear Sirs:
> > >      I'm learning how to use zookeeper. I've downloaded both the 3.2.0
> > and
> > > 3.3.3 versions. There are three zookeeper servers running on my PC with
> > the
> > > following configuration for each them, among which the dataDir and
> > > clientPort are configured differently:
> > >
> > > tickTime=2000
> > > initLimit=10
> > > syncLimit=5
> > > dataDir=/export/mahadev/zookeeper/server1/data
> > > clientPort=2181
> > > server.1=10.65.134.219:2888:3888
> > > server.2=10.65.134.219:2889:3889
> > > server.3=10.65.134.219:2890:3890
> > >
> > > I also wrote a client to report the PC performance information like
> > memory
> > > usage, network performance and idle cpu time to the zookeeper servers.
> > The
> > > report cycle is 2 seconds.
> > >
> > > But both versions of zookeeper throws the OutOfMemoryError exception
> when
> > > kept running for about 50 minutes. Is this due to a memory leak error
> > > inside
> > > the zookeeper itself or some miss configuration of myself?
> > >
> > > Thanks for your help:-)
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message