zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yang <teddyyyy...@gmail.com>
Subject Re: Connecting to ZK from windows box takes significantly longer than from linux
Date Fri, 22 Jul 2011 22:32:27 GMT
TCP dump also helps

On Fri, Jul 22, 2011 at 3:28 PM, Patrick Hunt <phunt@apache.org> wrote:
> Are you using the java or the c client binding? What version? I'd
> encourage you to enter a jira (and submit a patch if you figure it
> out).
>
> Regards,
>
> Patrick
>
> On Fri, Jul 22, 2011 at 2:56 PM, Sergei Babovich
> <sbabovich@demandware.com> wrote:
>> Hi everybody,
>>
>> I noticed quite strange thing: when connecting to the same ZK server from a
>> windows box it takes 4-5 seconds before receiving SyncConnected event, while
>> from linux machine it is under 10ms. All on the same network. The behaviour
>> is quite consistent across different windows boxes. As expected on a server
>> side interactions look identical - there is no delay in sending replies. At
>> this moment my only theory is some kind of delay by windows on
>> sending/receiving message. Anybody observed anything similar? Any clues
>> ideas will be very appreciated.
>>
>> Best regards,
>> Sergei
>> This e-mail message and all attachments transmitted with it may contain
>> privileged and/or confidential information intended solely for the use of
>> the addressee(s). If the reader of this message is not the intended
>> recipient, you are hereby notified that any reading, dissemination,
>> distribution, copying, forwarding or other use of this message or its
>> attachments is strictly prohibited. If you have received this message in
>> error, please notify the sender immediately and delete this message, all
>> attachments and all copies and backups thereof.
>>
>>
>

Mime
View raw message