zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Dunning <ted.dunn...@gmail.com>
Subject Re: why zookeeper bind 0.0.0.0 at mitihomed server
Date Wed, 15 Jun 2011 18:47:46 GMT
Jared,

Sounds like you have a quorum of users interested in this patch.

On Wed, Jun 15, 2011 at 2:55 PM, Jared Cantwell <jared.cantwell@gmail.com>wrote:

> I suggested something similar a while back.  I too don't see a reason to
> bind to all interfaces when we know the interface other servers are going
> to
> contact us on.  See this thread, where I propose a patch.  If there's
> interest, I can attach this patch to a JIRA you open.  I've been using this
> for about a year now.
>
>
> http://mail-archives.apache.org/mod_mbox/hadoop-zookeeper-dev/201008.mbox/%3CAANLkTikkT97Djqt3CU=H2+7Gnj_4p28hgCXjh345HiyN@mail.gmail.com%3E
>
> ~Jared
>
> On Wed, Jun 15, 2011 at 6:52 AM, Kiall Mac Innes <kiall@managedit.ie>
> wrote:
>
> > Obviously the server.* settings are for connecting to other servers, I
> > believe he is referring to the clientPort and clientPortAddress
> > combination.
> > These looks suspiciously like they are for choosing an IP and Port combo
> to
> > bind on..
> >
> >
> > Thanks,
> > Kiall
> >
> >
> > On Wed, Jun 15, 2011 at 8:53 AM, Ted Dunning <ted.dunning@gmail.com>
> > wrote:
> >
> > > So that other machines can contact it.
> > >
> > > Seriously, why did you have an expectation it would not bind to
> 0.0.0.0?
> > >
> > > The configuration file tells how to reach OTHER servers.  It doesn't
> > > limit which interfaces to use for incoming connections.
> > >
> > > On Wed, Jun 15, 2011 at 5:33 AM, Isaac <isaac.198@gmail.com> wrote:
> > > > why zookeeper bind 0.0.0.0 at miti-homed server?
> > > >
> > > > $ netstat -lnp | grep 99
> > > > ...
> > > > tcp        0      0 0.0.0.0:9900            0.0.0.0:*
> > > LISTEN
> > > >   16536/java
> > > > tcp        0      0 0.0.0.0:9910            0.0.0.0:*
> > > LISTEN
> > > >   16536/java
> > > > ...
> > > >
> > > > i deploy 3 zookeeper on the same server for test.
> > > > zoo.cfg
> > > > ------------------------------
> > > > # The number of milliseconds of each tick
> > > > tickTime=2000
> > > > # The number of ticks that the initial
> > > > # synchronization phase can take
> > > > initLimit=5
> > > > # The number of ticks that can pass between
> > > > # sending a request and getting an acknowledgement
> > > > syncLimit=2
> > > > # the directory where the snapshot is stored.
> > > > dataDir=/data/zookeeper/data
> > > > # the port at which the clients will connect
> > > > clientPort=10000
> > > > clientPortAddress=172.27.31.48
> > > > server.1=172.27.31.48:9900:9910
> > > > server.2=172.27.31.48:9901:9911
> > > > server.3=172.27.31.48:9902:9912
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message