zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Hunt <ph...@apache.org>
Subject Re: Help to compile Zookeeper C API on a old system
Date Tue, 07 Jul 2009 16:16:04 GMT
We'd be happy to take a look, create a JIRA here and attach your patch:
https://issues.apache.org/jira/browse/ZOOKEEPER

Easiest way to create the patch is to use SVN and do a "svn diff". More 
details here, please feel free to join the zookeeper-dev mailing list, 
that's the main list for development related discussion:
http://wiki.apache.org/hadoop/ZooKeeper/HowToContribute

Thanks!

Patrick

Qian Ye wrote:
> Hi Mahadev:
> 
> After modified some code, I have build Zookeeper C API (3.1.1) on the old
> system successfully. I have done some simple test, it works.
> 
> Thanks for your help, I wonder whether I can submit my modification to you,
> after all it is a more universal version
> 
> 
> On Tue, Jul 7, 2009 at 9:56 AM, Mahadev Konar <mahadev@yahoo-inc.com> wrote:
> 
>> Hi Qian,
>>  I am not sure if it will work. You should be able to back port it such a
>> way so that it works with gcc 3.*/4.*, but again I have never tried it.
>>
>> mahadev
>>
>>
>> On 7/6/09 6:35 PM, "Qian Ye" <yeqian.zju@gmail.com> wrote:
>>
>>> Thanks Mahadev,  I follow the installation instruction in the README,
>>>
>>> autoreconf -i -f
>>> ./configure --prefix=$dir
>>> make
>>> make install
>>>
>>> until "./configure --prefix=$dir", there is no error, however, errors
>> came
>>> when I did make,
>>>
>>> My plan is change the compiler from gcc to g++, and solve the compile
>> errors
>>> one by one.
>>>
>>> Will my plan do?
>>>
>>> Thanks~
>>>
>>>
>>> On Tue, Jul 7, 2009 at 2:22 AM, Mahadev Konar <mahadev@yahoo-inc.com>
>> wrote:
>>>> Hi Qian,
>>>>  What issues do you face? I have never tried compiling with the
>>>> configuration below, but I could give it a try in my free time to see if
>> I
>>>> can get it to compile.
>>>>
>>>> mahadev
>>>>
>>>>
>>>> On 7/6/09 7:37 AM, "Qian Ye" <yeqian.zju@gmail.com> wrote:
>>>>
>>>>> Hi all:
>>>>>
>>>>> I'm writing to ask you to do me a favor. It's urgent. For some
>>>> unchangeable
>>>>> reason, I have to compile "libzookeeper_st.a", "libzookeeper_mt.a" on
>> an
>>>> old
>>>>> system:
>>>>>
>>>>> gcc 2.96
>>>>> autoconf 2.13
>>>>> automake 1.4-p5
>>>>> libtool 1.4.2
>>>>>
>>>>> I cannot not compile the target lib in the usual way, and this task
>>>> drives
>>>>> me crazy :-(
>>>>>
>>>>> could anyone help me out? Thanks a lot~
>>>>
>>
> 
> 

Mime
View raw message