zookeeper-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andor Molnar (Jira)" <j...@apache.org>
Subject [jira] [Created] (ZOOKEEPER-3568) Remove Netty support from 3.4
Date Thu, 03 Oct 2019 20:54:00 GMT
Andor Molnar created ZOOKEEPER-3568:
---------------------------------------

             Summary: Remove Netty support from 3.4
                 Key: ZOOKEEPER-3568
                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-3568
             Project: ZooKeeper
          Issue Type: Task
          Components: java client, server
    Affects Versions: 3.4.14
            Reporter: Andor Molnar
             Fix For: 3.4.15


branch-3.4 is still on Netty 3 which is not maintained by the Netty-team anymore. We have
no intention of upgrading to the new version, instead we propose to remove Netty from the
entire 3.4 codebase and encourage users to upgrade to 3.5 which is stable and backward compatible.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message