zookeeper-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enrico Olivelli (Jira)" <j...@apache.org>
Subject [jira] [Updated] (ZOOKEEPER-2128) zoo_aremove_watchers API is incorrect
Date Fri, 06 Sep 2019 15:43:13 GMT

     [ https://issues.apache.org/jira/browse/ZOOKEEPER-2128?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Enrico Olivelli updated ZOOKEEPER-2128:
---------------------------------------
    Fix Version/s: 3.5.7

> zoo_aremove_watchers API is incorrect
> -------------------------------------
>
>                 Key: ZOOKEEPER-2128
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-2128
>             Project: ZooKeeper
>          Issue Type: Bug
>    Affects Versions: 3.6.0
>            Reporter: Dave Gosselin
>            Assignee: Dave Gosselin
>            Priority: Major
>             Fix For: 3.6.0, 3.5.6, 3.5.7
>
>
> The C API for zoo_aremove_watchers incorrectly specifies the seventh argument as a pointer
to a function pointer.  It should be simply a function pointer only.



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

Mime
View raw message