zookeeper-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enrico Olivelli (Jira)" <j...@apache.org>
Subject [jira] [Updated] (ZOOKEEPER-1896) Reconfig error messages when upgrading from 3.4.6 to 3.5.0
Date Fri, 06 Sep 2019 15:42:06 GMT

     [ https://issues.apache.org/jira/browse/ZOOKEEPER-1896?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Enrico Olivelli updated ZOOKEEPER-1896:
---------------------------------------
    Fix Version/s: 3.5.7

> Reconfig error messages when upgrading from 3.4.6 to 3.5.0
> ----------------------------------------------------------
>
>                 Key: ZOOKEEPER-1896
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-1896
>             Project: ZooKeeper
>          Issue Type: Bug
>          Components: server
>    Affects Versions: 3.5.0
>            Reporter: Raul Gutierrez Segales
>            Priority: Major
>             Fix For: 3.6.0, 3.5.6, 3.5.7
>
>
> When upgrading from 3.4.6 (rc0 actually) to 3.5.0 (trunk as of two weeks ago actually)
I got this error message:
> {noformat}
> 2014-02-26 22:12:15,446 - ERROR [WorkerReceiver[myid=4]] - Something went wrong while
processing config received from 3
> {noformat}
> According to [~fpj]:
> bq. I think you’re right that the reconfig error is harmless, but we shouldn’t be
getting it. The problem is that it is not detecting that we are in backward compatibility
mode. We need to fix it for 3.5.0 and perhaps ZOOKEEPER-1805 is the right place for doing
it.
> cc: [~shralex]



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

Mime
View raw message