zookeeper-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ZOOKEEPER-3494) No need to depend on netty-all (SSL)
Date Mon, 05 Aug 2019 13:04:00 GMT

    [ https://issues.apache.org/jira/browse/ZOOKEEPER-3494?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16900065#comment-16900065
] 

Hadoop QA commented on ZOOKEEPER-3494:
--------------------------------------

-1 overall.  GitHub Pull Request  Build
      

    +1 @author.  The patch does not contain any @author tags.

    +0 tests included.  The patch appears to be a documentation patch that doesn't require
tests.

    +1 javadoc.  The javadoc tool did not generate any warning messages.

    +1 javac.  The applied patch does not increase the total number of javac compiler warnings.

    +1 findbugs.  The patch does not introduce any new Findbugs (version 3.0.1) warnings.

    +1 release audit.  The applied patch does not increase the total number of release audit
warnings.

    -1 core tests.  The patch failed core unit tests.

    +1 contrib tests.  The patch passed contrib unit tests.

Test results: https://builds.apache.org/job/PreCommit-ZOOKEEPER-github-pr-build/4094//testReport/
Findbugs warnings: https://builds.apache.org/job/PreCommit-ZOOKEEPER-github-pr-build/4094//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
Console output: https://builds.apache.org/job/PreCommit-ZOOKEEPER-github-pr-build/4094//console

This message is automatically generated.

> No need to depend on netty-all (SSL)
> ------------------------------------
>
>                 Key: ZOOKEEPER-3494
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-3494
>             Project: ZooKeeper
>          Issue Type: Improvement
>    Affects Versions: 3.6.0, 3.5.5
>            Reporter: Norbert Kalmar
>            Assignee: Norbert Kalmar
>            Priority: Major
>              Labels: pull-request-available
>          Time Spent: 10m
>  Remaining Estimate: 0h
>
> ZooKeeper currently depends on netty-all to satisfy the requirements for the SSL capability.
> netty-all is an unnecessarily broad dependency, we already had request to revise (https://issues.apache.org/jira/browse/SOLR-13665)
> netty-handler (429KB) and netty-transport-native-epoll (115KB) looks like is enough.

> Netty-all was ~4MB. 
> This reduce size of netty dependency to 1/8.



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

Mime
View raw message