zookeeper-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Norbert Kalmar (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ZOOKEEPER-3494) No need to depend on netty-all (SSL)
Date Mon, 05 Aug 2019 11:48:00 GMT

     [ https://issues.apache.org/jira/browse/ZOOKEEPER-3494?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Norbert Kalmar updated ZOOKEEPER-3494:
--------------------------------------
    Affects Version/s: 3.6.0

> No need to depend on netty-all (SSL)
> ------------------------------------
>
>                 Key: ZOOKEEPER-3494
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-3494
>             Project: ZooKeeper
>          Issue Type: Improvement
>    Affects Versions: 3.6.0
>            Reporter: Norbert Kalmar
>            Assignee: Norbert Kalmar
>            Priority: Major
>
> ZooKeeper currently depends on netty-all to satisfy the requirements for the SSL capability.
> netty-all is an unnecessarily broad dependency, we already had request to revise (https://issues.apache.org/jira/browse/SOLR-13665)
> netty-handler and netty-transport-native-epoll looks like is enough.



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

Mime
View raw message