zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Enrico Olivelli <eolive...@gmail.com>
Subject BouncyCastle version different from Maven and Ant builds
Date Wed, 06 Feb 2019 21:35:38 GMT
Hi,
while working on OWASP stuff I have found that Maven dependency of
BouncyCastle is newer than the one in the Ant configuration.
The same is on branch-3.5.
On branch-3.4 we have bouncycastle only on Maven (I am sending a patch
for this one)

see:
https://github.com/apache/zookeeper/blob/af741cb319d4760cfab1cd3b560635adacd8deca/pom.xml#L279
https://github.com/apache/zookeeper/blob/af741cb319d4760cfab1cd3b560635adacd8deca/build.xml#L47

I wil be happy to send a patch, but we should decide for a roadmap

This makes me think we should step out of this dual-configuration as
soon as possible.

Enrico

Mime
View raw message