zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enrico Olivelli (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ZOOKEEPER-3256) Enable OWASP checks to Maven build
Date Fri, 25 Jan 2019 22:11:00 GMT

    [ https://issues.apache.org/jira/browse/ZOOKEEPER-3256?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16752730#comment-16752730
] 

Enrico Olivelli commented on ZOOKEEPER-3256:
--------------------------------------------

while executing ant task I am seeing

[owasp:dependency-check] A new version of dependency-check is available. Consider updating
to version 4.0.2.
[

> Enable OWASP checks  to Maven build
> -----------------------------------
>
>                 Key: ZOOKEEPER-3256
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-3256
>             Project: ZooKeeper
>          Issue Type: Sub-task
>          Components: security
>            Reporter: Enrico Olivelli
>            Assignee: Enrico Olivelli
>            Priority: Major
>              Labels: pull-request-available
>             Fix For: 3.6.0, 3.5.5, 3.4.14
>
>          Time Spent: 20m
>  Remaining Estimate: 0h
>
> Port OWASP check task to the Maven build, the suppressionsFile is the same as the ANT
task
> use this command to run the check:
> {code:java}
> mvn org.owasp:dependency-check-maven:aggregate{code}
>  
> ant based counterpart is:
> {code:java}
> ant owasp{code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message