zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] eolivelli commented on issue #788: ZOOKEEPER-3256: Enable OWASP checks to Maven build
Date Fri, 25 Jan 2019 21:58:26 GMT
eolivelli commented on issue #788: ZOOKEEPER-3256: Enable OWASP checks  to Maven build
URL: https://github.com/apache/zookeeper/pull/788#issuecomment-457744846
 
 
   @anmolnar  @nkalmar this patch is currenaly a WIP because on my laptop the check is failing
with:
   [ERROR] Failed to execute goal org.owasp:dependency-check-maven:4.0.2:check (default-cli)
on project zookeeper-server: 
   [ERROR] 
   [ERROR] One or more dependencies were identified with vulnerabilities that have a CVSS
score greater than or equal to '0,0': 
   [ERROR] 
   [ERROR] zookeeper-jute-3.6.0-SNAPSHOT.jar: CVE-2018-8012
   [ERROR] netty-all-4.1.29.Final.jar: CVE-2018-12056
   [ERROR] jetty-http-9.4.10.v20180503.jar: CVE-2017-7656, CVE-2017-7658, CVE-2017-7657, CVE-2018-12536
   [ERROR] jackson-databind-2.9.5.jar: CVE-2018-14719, CVE-2018-1000873, CVE-2018-14718, CVE-2018-19362,
CVE-2018-19361, CVE-2018-19360, CVE-2018-14721, CVE-2018-14720
   [ERROR] bcprov-jdk15on-1.56.jar: CVE-2017-13098, CVE-2018-1000180, CVE-2018-1000613
   [ERROR] 
   [ERROR] See the dependency-check report for more details.
   

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


With regards,
Apache Git Services

Mime
View raw message