zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Akira Ajisaka (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ZOOKEEPER-3181) ZOOKEEPER-2355 broke Curator TestingQuorumPeerMain
Date Wed, 24 Oct 2018 04:07:00 GMT

    [ https://issues.apache.org/jira/browse/ZOOKEEPER-3181?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16661697#comment-16661697
] 

Akira Ajisaka commented on ZOOKEEPER-3181:
------------------------------------------

Recently Apache Hadoop upgraded ZooKeeper from 3.4.8 to 3.4.13 due to security concern (HADOOP-15816).
And then ZK tests fail because Hadoop is using Curator 2.12.0 (YARN-8937).

> ZOOKEEPER-2355 broke Curator TestingQuorumPeerMain
> --------------------------------------------------
>
>                 Key: ZOOKEEPER-3181
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-3181
>             Project: ZooKeeper
>          Issue Type: Bug
>    Affects Versions: 3.5.3, 3.4.11
>            Reporter: Akira Ajisaka
>            Priority: Major
>
> ZOOKEEPER-2355 added a getQuorumPeer method to QuorumPeerMain [https://github.com/apache/zookeeper/blob/release-3.5.3/src/java/main/org/apache/zookeeper/server/quorum/QuorumPeerMain.java#L194].
TestingQuorumPeerMain has an identically named method, which is now unintentionally overridding
the one in the base class.
> This is fixed by CURATOR-409, however, I'd like this to be fixed in ZooKeeper as well.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message