zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From eolivelli <...@git.apache.org>
Subject [GitHub] zookeeper pull request #626: ZOOKEEPER-3148 Add Kerberos tests for modern JD...
Date Fri, 14 Sep 2018 15:05:12 GMT
GitHub user eolivelli opened a pull request:

    https://github.com/apache/zookeeper/pull/626

    ZOOKEEPER-3148 Add Kerberos tests for modern JDKs

    - This change is only for 3.4 branch, which MUST be compatible with JDK6
    - Add Kerby and upgrade commons-io to 2.6, as needed by Kerby
    - Copy Kerberos tests from branch-3.5 in a new package o.a.zookeeper.server.quorum.authnew
    - Mark Kerberos tests to be executed only on JDK6 VMs
    - Java version is done using system property, this is the safer way without introducing
external libs

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/eolivelli/zookeeper fix/34-kerby-jdk11

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/zookeeper/pull/626.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #626
    
----
commit 1fd6282aa6c139b84c1c6bc60fb738819d8e7574
Author: Enrico Olivelli <eolivelli@...>
Date:   2018-09-13T18:04:41Z

    ZOOKEEPER-3148 Add Kerberos tests for modern JDKs
    - This change is only for 3.4 branch, which MUST be compatible with JDK6
    - Add Kerby and upgrade commons-io to 2.6, as needed by Kerby
    - Copy Kerberos tests from branch-3.5 in a new package o.a.zookeeper.server.quorum.authnew
    - Mark Kerberos tests to be executed only on JDK6 VMs
    - Java version is done using system property, this is the safer way without introducing
external libs

----


---

Mime
View raw message